Puggle

A A A A Author Topic: Leak  (Read 117 times)

blackmarkus

Leak
« Started on: 19-May-21, 15:29 »
I have a leak, wondering if you think it would be the o-ring or mechanic water seal. I did change the seal about 30,000 kms ago. Just pulled the mikunis off to fit my Ran-San electronic ignition module

Seagrass

Re: Leak
« Reply #1 on: 19-May-21, 17:34 »
I am sorry to say it looks like a weep from the mechanical seal weep hole.

Is your coolant rusty or this that an optical illusion?

If you are using one of the OAT coolants that is red this will result in the solder joints in your radiator erroding away so you might want to consider changing to an ethylene glycol based coolant or one of the new coolants that don’t affect solder.

Seagrass

blackmarkus

Re: Leak
« Reply #2 on: 19-May-21, 17:45 »
It’s bright green. No problem anyway, not far off a frame swap. Will order another seal. Any idea where I get one from ? My last one wasn’t Honda

Seagrass

Re: Leak
« Reply #3 on: 19-May-21, 18:48 »
Not easy to get Honda ones any more and if you can get them they are around $80 or so.

Most of us are sourcing them from AE Seals these days for around $20

Send a PM to CX Phreak as he was supplying them for a while so he may he able to help you.

Seagrass

blackmarkus

Re: Leak
« Reply #4 on: 19-May-21, 18:53 »
Thanks, he organised my first one years ago

 


Website and forum protected by
 STOP FORUM SPAM     Bad Behavior     Let's Encrypt

SimplePortal 2.3.6 © 2008-2014, SimplePortal